Meerdere kwetsbaarheden verholpen in MySQL en MariaDB

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.05 14-08-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
14-08-2019
medium
high
NCSC-2019-0323 [1.05] Signed-PGP →
Kenmerken

Kenmerken

  • Denial-of-Service (DoS)
  • (Remote) code execution (Gebruikersrechten)
  • Toegang tot gevoelige gegevens
Omschrijving

Omschrijving

Er bevinden zich meerdere kwetsbaarheden in MySQL. Een kwaadwillende op afstand kan de kwetsbaarheden mogelijk misbruiken om:

* willekeurige code uit te voeren met de rechten van de applicatie; * een Denial-of-Service-aanval uit te voeren; * gevoelige informatie te bemachtigen.

Bereik

Bereik

Platforms Producten Versies

FreeBSD
SUSE
Ubuntu

MariaDB
MySQL

<= 5.3.12 <= 5.6.43 <= 5.7.25 <= 8.0.15

Oplossingen

Oplossingen

Oracle heeft updates uitgebracht om de kwetsbaarheden te verhelpen in zijn Critical Patch Update van april 2019. U kunt de updates downloaden van de website van Oracle. Voor meer informatie, zie [Link]

FreeBSD

FreeBSD heeft updates beschikbaar gesteld om de kwetsbaarheden te verhelpen in mariadb55-server, mariadb101-server, mariadb102-server, mariadb103-server, mysql56-server, mysql57-server en mysql80-server. U kunt deze updates installeren uit de FreeBSD ports. Meer informatie over deze updates [Link]

SUSE

SUSE heeft updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in SUSE Linux Enterprise Module for Basesystem 15 en 15-SP1. U kunt deze aangepaste packages installeren door gebruik te maken van 'YaST'. U kunt de packages ook handmatig downloaden van de SUSE FTP-server (ftp.suse.com). Voor meer informatie, zie [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 14.04 LTS, 16.04 LTS, 18.04 LTS, 18.10 en 19.04 om de kwetsbaarheden te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op onderstaande pagina:

MariaDB (CVE-2019-2614, CVE-2019-2627 en CVE-2019-2628) [Link]

MySQL [Link]

CVE’s

CVE’s

CVE-2018-0734, CVE-2018-3123, CVE-2018-5407, CVE-2019-1559, CVE-2019-2566, CVE-2019-2580, CVE-2019-2581, CVE-2019-2584, CVE-2019-2585, CVE-2019-2587, CVE-2019-2589, CVE-2019-2592, CVE-2019-2593, CVE-2019-2596, CVE-2019-2606, CVE-2019-2607, CVE-2019-2614, CVE-2019-2617, CVE-2019-2620, CVE-2019-2623, CVE-2019-2624, CVE-2019-2625, CVE-2019-2626, CVE-2019-2627, CVE-2019-2628, CVE-2019-2630, CVE-2019-2631, CVE-2019-2632, CVE-2019-2634, CVE-2019-2635, CVE-2019-2636, CVE-2019-2644, CVE-2019-2681, CVE-2019-2683, CVE-2019-2685, CVE-2019-2686, CVE-2019-2687, CVE-2019-2688, CVE-2019-2689, CVE-2019-2691, CVE-2019-2692, CVE-2019-2693, CVE-2019-2694, CVE-2019-2695

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 24
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Onduidelijk/Ja 3
Is er exploit-code beschikbaar? Nee (nog niet) 1
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Beperkt 2
Welke toegang is er nodig? LAN/directe omgeving 4
Vereiste credentials Geen 4
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Gemiddeld 2
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Niet op korte termijn 1
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

high
Denial of Service Ja, Infrastructuur dienst
high
Uitvoeren van willekeurige code Ja, Gebruikersrechten
medium
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Nee
low
Lekken van (gevoelige) informatie Ja, Gebruikersdata
high
  Versie 1.05 14-08-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
14-08-2019
medium
high
NCSC-2019-0323 [1.05] Signed-PGP →
Update

Update

De ontwikkelaars van Ubuntu hebben updates uitgegeven om de kwetsbaarheden met de kenmerken CVE-2019-2614, CVE-2019-2627 en CVE-2019-2628 te verhelpen in MariaDB.

  Versie 1.04 31-07-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
31-07-2019
medium
high
NCSC-2019-0323 [1.04] Signed-PGP →
Update

Update

De ontwikkelaars van SUSE hebben updates uitgegeven om de kwetsbaarheden met de kenmerken CVE-2019-2614, CVE-2019-2627 en CVE-2019-2628 te verhelpen in MariaDB.

  Versie 1.03 06-06-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
06-06-2019
medium
high
NCSC-2019-0323 [1.03] Signed-PGP →
Update

Update

Ubuntu heeft updates uitgebracht om de kwetsbaarheden met kenmerk CVE-2019-2614 en CVE-2019-2627 te verhelpen in MariaDB.

  Versie 1.02 30-04-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
30-04-2019
medium
high
NCSC-2019-0323 [1.02] Signed-PGP →
Update

Update

Canonical heeft updates uitgebracht voor Ubuntu. Voor meer informatie zie "Mogelijke oplossingen".

  Versie 1.01 18-04-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
18-04-2019
medium
high
NCSC-2019-0323 [1.01] Signed-PGP →
Update

Update

De ontwikkelaars van FreeBSD hebben updates beschikbaar gesteld om de kwetsbaarheden in MySQL te verhelpen.

  Versie 1.00 17-04-2019 NCSC-2019-0323  
 
medium
high
Signed-PGP →  
17-04-2019
medium
high
NCSC-2019-0323 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.