Kwetsbaarheid verholpen in sudo

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.07 11-11-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
11-11-2019
medium
high
NCSC-2019-0799 [1.07] Signed-PGP →
Kenmerken

Kenmerken

  • Omzeilen van beveiligingsmaatregel
Omschrijving

Omschrijving

Er is een kwetsbaarheid verholpen in sudo waarmee een kwaadwillende beveiligingsmaatregelen in /etc/sudoers kan omzeilen. Een kwaadwillende met gebruikersrechten kan door het misbruiken van deze kwetsbaarheid niet toegestane commando's uitvoeren als root.

Bereik

Bereik

Platforms Producten Versies

Oracle Linux
Debian Fedora Linux OpenSUSE Red Hat Enterprise Linux
SUSE Ubuntu

sudo

< 1.8.28

Oplossingen

Oplossingen

De ontwikkelaars van sudo hebben nieuwe versies uitgebracht van sudo. Meer informatie vindt u in de beveiligingsadviezen van de sudo ontwikkelaars [Link]

Debian

Debian heeft updates beschikbaar gesteld voor Debian 9.0 (Stretch)en Debian 10.0 (Buster) om de kwetsbaarheid te verhelpen. U kunt de
aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

OpenSUSE

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in OpenSUSE Leap 15.0 en Leap 15.1. U kunt deze aangepaste packages installeren door gebruik te maken van 'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig downloaden van de OpenSUSE downloadserver (download.opensuse.org). Voor meer informatie, zie:

openSUSE Leap 15.0 [Link]

OpenSUSE Leap 15.1 [Link]

Oracle

Oracle heeft updates beschikbaar gesteld voor Oracle Linux 6. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

Red Hat

Red Hat heeft updates beschikbaar gesteld voor Red Hat Enterprise Linux 6, 7 en 8. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:

Red Hat Enterprise Linux 6 [Link]

Red Hat Enterprise Linux 7 [Link]

Red Hat Enterprise Linux 8 [Link]

SUSE

SUSE heeft updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in SUSE 12 en 15. U kunt deze aangepaste packages installeren door gebruik te maken van 'YaST'. U kunt de packages ook handmatig downloaden van de SUSE FTP-server (ftp.suse.com). Voor meer informatie, zie:

SUSE 12 [Link]

SUSE 15 [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 19.04 om de kwetsbaarheid te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

Fedora

Fedora heeft updates beschikbaar gesteld voor Fedora 29 en 30. U kunt deze updates installeren met behulp van het commando 'dnf' of 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:

Fedora 29 [Link]

Fedora 30 [Link]

CVE’s

CVE’s

CVE-2019-14287

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 26
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Nee 1
Is er exploit-code beschikbaar? Exploit beschikbaar 6
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Ja, volledig 3
Welke toegang is er nodig? Fysiek 1
Vereiste credentials Gewone gebruiker 2
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Eenvoudig 3
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Ja binnenkort 3
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

high
Denial of Service Nee
low
Uitvoeren van willekeurige code Ja, Root/Administrator-rechten
high
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Nee
low
Lekken van (gevoelige) informatie Nee
low
  Versie 1.07 11-11-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
11-11-2019
medium
high
NCSC-2019-0799 [1.07] Signed-PGP →
Update

Update

Oracle heeft updates beschikbaar gesteld voor sudo.

  Versie 1.06 07-11-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
07-11-2019
medium
high
NCSC-2019-0799 [1.06] Signed-PGP →
Update

Update

Red Hat heeft updates beschikbaar gesteld voor sudo.

  Versie 1.05 06-11-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
06-11-2019
medium
high
NCSC-2019-0799 [1.05] Signed-PGP →
Update

Update

Red Hat heeft updates beschikbaar gesteld voor sudo.

  Versie 1.04 31-10-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
31-10-2019
medium
high
NCSC-2019-0799 [1.04] Signed-PGP →
Update

Update

Fedora heeft updates uitgebracht om de kwetsbaarheid te verhelpen
in Fedora 29.

  Versie 1.03 24-10-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
24-10-2019
medium
high
NCSC-2019-0799 [1.03] Signed-PGP →
Update

Update

Red Hat heeft updates beschikbaar gesteld voor sudo.

  Versie 1.02 18-10-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
18-10-2019
medium
high
NCSC-2019-0799 [1.02] Signed-PGP →
Update

Update

OpenSUSE heeft updates beschikbaar gesteld om de kwetsbaarheid in
openSUSE Leap 15.0 te verhelpen

  Versie 1.01 16-10-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
16-10-2019
medium
high
NCSC-2019-0799 [1.01] Signed-PGP →
Update

Update

Fedora heeft updates beschikbaar gesteld voor Fedora 30. Open

  Versie 1.00 15-10-2019 NCSC-2019-0799  
 
medium
high
Signed-PGP →  
15-10-2019
medium
high
NCSC-2019-0799 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.