Kwetsbaarheden verholpen in PostgreSQL

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.03 vandaag NCSC-2020-0942  
 
medium
high
Signed-PGP →  
vandaag
medium
high
NCSC-2020-0942 [1.03] Signed-PGP →
Kenmerken

Kenmerken

  • (Remote) code execution (Administrator/Root rechten)
  • Toegang tot gevoelige gegevens
Omschrijving

Omschrijving

Er zijn meerdere kwetsbaarheden verholpen in PostgreSQL. Een lokale kwaadwillende met beperkte rechten binnen de kwetsbare PostgreSQL-database, kan de kwetsbaarheden mogelijk misbruiken om binnen de database of op het lokale systeem willekeurige code uit te voeren met root-rechten. Tevens maken de kwetsbaarheden het voor de kwaadwillende mogelijk om toegang te verkrijgen tot de in de database opgeslagen gegevens.

Bereik

Bereik

Platforms Producten Versies

Ubuntu
SUSE

PostgreSQL Database

< 9.5.24 < 9.6.20 < 10.15 < 11.10 < 12.5 < 13.1

Oplossingen

Oplossingen

De ontwikkelaars van PostgreSQL heeft updates uitgebracht om de kwetsbaarheden te verhelpen in PostgreSQL 9.5.24, 9.6.20, 10.15, 11.10, 12.5 en 13.1. Voor meer informatie, zie [Link]

SUSE

SUSE heeft updates beschikbaar gesteld om de kwetsbaarheden te verhelpen in SUSE 12 en 15. U kunt deze aangepaste packages installeren door gebruik te maken van 'YaST'. U kunt de packages ook handmatig downloaden van de SUSE FTP-server (ftp.suse.com). Voor meer informatie, zie:

SUSE 12-SP2-LTSS en hoger, PostgreSQL 10 [Link]

SUSE 15-SP1 en 15-SP2 PostgreSQL 10 [Link]

SUSE 15-SP1 PostgreSQL 12 [Link]

SUSE 15-SP2 PostgreSQL 12 [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS en 20.10 om de kwetsbaarheden te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

CVE’s

CVE’s

CVE-2020-25694, CVE-2020-25695, CVE-2020-25696

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 22
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Onduidelijk/Ja 3
Is er exploit-code beschikbaar? Nee (nog niet) 1
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Beperkt 2
Welke toegang is er nodig? LAN/directe omgeving 4
Vereiste credentials Gewone gebruiker 2
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Gemiddeld 2
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Niet op korte termijn 1
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

high
Denial of Service Nee
low
Uitvoeren van willekeurige code Ja, Root/Administrator-rechten
high
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Nee
low
Lekken van (gevoelige) informatie Ja, Gebruikersdata
high
  Versie 1.03 vandaag NCSC-2020-0942  
 
medium
high
Signed-PGP →  
vandaag
medium
high
NCSC-2020-0942 [1.03] Signed-PGP →
Update

Update

SUSE heeft updates beschikbaar gesteld voor SUSE 12 en 15 om de kwetsbaarheden in PostgreSQL te verhelpen.

  Versie 1.02 20-11-2020 NCSC-2020-0942  
 
medium
high
Signed-PGP →  
20-11-2020
medium
high
NCSC-2020-0942 [1.02] Signed-PGP →
Update

Update

SUSE heeft updates beschikbaar gesteld voor SUSE 15 om de kwetsbaarheden in PostgreSQL te verhelpen.

  Versie 1.01 18-11-2020 NCSC-2020-0942  
 
medium
high
Signed-PGP →  
18-11-2020
medium
high
NCSC-2020-0942 [1.01] Signed-PGP →
Update

Update

Canonical heeft updates beschikbaar gesteld voor Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS en 20.10 om de kwetsbaarheden in PostgreSQL te verhelpen.

  Versie 1.00 16-11-2020 NCSC-2020-0942  
 
medium
high
Signed-PGP →  
16-11-2020
medium
high
NCSC-2020-0942 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.