Kwetsbaarheid verholpen in Squid

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.05 12-04-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
12-04-2021
medium
medium
NCSC-2021-0231 [1.05] Signed-PGP →
Kenmerken

Kenmerken

  • Omzeilen van beveiligingsmaatregel
Omschrijving

Omschrijving

De ontwikkelaars van Squid hebben een kwetsbaarheid verholpen. Een geauthenticeerde gebruiker kan de kwetsbaarheid middels een HTTP-Request Smuggling aanval misbruiken om alsnog toegang te krijgen tot diensten en websites die door Squid zouden moeten worden afgeschermd.

Bereik

Bereik

Platforms Producten Versies

Debian
Fedora
Oracle Enterprise Linux
Red Hat Enterprise Linux
Ubuntu

Squid

< 4.14 < 5.0.5

Oplossingen

Oplossingen

Squid heeft updates uitgebracht om de kwetsbaarheid te verhelpen in Squid v 4.14 en 5.0.5. Voor meer informatie, zie [Link]

Debian

Debian heeft updates van squid3 beschikbaar gesteld voor Debian 9.0 (Stretch) en Debian 10.0 (Buster) om de kwetsbaarheden te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op onderstaande pagina:

Debian 9.0 [Link]

Debian 10.0 [Link]

Fedora

Fedora heeft updates beschikbaar gesteld voor Fedora 32 en 33. U kunt deze updates installeren met behulp van het commando 'dnf' of 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:

Fedora 32 [Link]

Fedora 33 [Link]

Oracle

Oracle heeft updates beschikbaar gesteld voor Oracle Linux 7. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

Red Hat

Red Hat heeft updates beschikbaar gesteld voor Red Hat Enterprise Linux 7. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS en 20.10 om de kwetsbaarheid te verhelpen. Middels deze updates wordt tevens de kwetsbaarheid met kenmerk CVE-2020-15049 verholpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

CVE’s

CVE’s

CVE-2020-25097

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 24
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Onduidelijk/Ja 3
Is er exploit-code beschikbaar? Nee (nog niet) 1
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Beperkt 2
Welke toegang is er nodig? Internet 6
Vereiste credentials Gewone gebruiker 2
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Gemiddeld 2
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Niet op korte termijn 1
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

medium
Denial of Service Nee
low
Uitvoeren van willekeurige code Nee
low
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Ja
medium
Lekken van (gevoelige) informatie Nee
low
  Versie 1.05 12-04-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
12-04-2021
medium
medium
NCSC-2021-0231 [1.05] Signed-PGP →
Update

Update

Fedora heeft updates beschikbaar gesteld voor Fedora 32 en 33 om de kwetsbaarheid te verhelpen.

  Versie 1.04 09-04-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
09-04-2021
medium
medium
NCSC-2021-0231 [1.04] Signed-PGP →
Update

Update

Er zijn updates uitgebracht om de kwetsbaarheid te verhelpen in respectievelijk Oracle Enterprise Linux en Red Hat Enterprise Linux.

  Versie 1.03 30-03-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
30-03-2021
medium
medium
NCSC-2021-0231 [1.03] Signed-PGP →
Update

Update

Canonical heeft updates beschikbaar gesteld voor Ubuntu 16.04 LTS, 18.04 LTS, 20.04 LTS en 20.10 om de kwetsbaarheid te verhelpen. Middels deze updates wordt tevens de kwetsbaarheid met kenmerk CVE-2020-15049 verholpen.

  Versie 1.02 26-03-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
26-03-2021
medium
medium
NCSC-2021-0231 [1.02] Signed-PGP →
Update

Update

Debian heeft updates uitgebracht om de kwetsbaarheid te verhelpen in Debian 10.0 (Buster).

  Versie 1.01 19-03-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
19-03-2021
medium
medium
NCSC-2021-0231 [1.01] Signed-PGP →
Update

Update

Debian heeft updates uitgebracht om de kwetsbaarheid te verhelpen.

  Versie 1.00 10-03-2021 NCSC-2021-0231  
 
medium
medium
Signed-PGP →  
10-03-2021
medium
medium
NCSC-2021-0231 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.