Kwetsbaarheden verholpen in Exim

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.03 vandaag NCSC-2021-0391  
 
high
high
Signed-PGP →  
vandaag
high
high
NCSC-2021-0391 [1.03] Signed-PGP →
Kenmerken

Kenmerken

  • Denial-of-Service (DoS)
  • (Remote) code execution (Administrator/Root rechten)
  • (Remote) code execution (Gebruikersrechten)
  • Verhoogde gebruikersrechten
Omschrijving

Omschrijving

Er zijn kwetsbaarheden verholpen in Exim. Gezamenlijk hebben deze kwetsbaarheden de naam "21nails" gekregen. De kwetsbaarheden stellen een kwaadwillende in staat aanvallen uit te voeren die leiden tot de volgende categorieën schade:

  • Denial-of-Service (DoS)
  • (Remote) code execution (Administrator/Root rechten)
  • (Remote) code execution (Gebruikersrechten)
  • Verhoogde gebruikersrechten

De kwetsbaarheid met CVE-kenmerk CVE-2020-28021 stelt een geauthenticeerde gebruiker van de e-mail server in staat om willekeurige code uit te voeren op het systeem met de rechten van de root gebruiker. In combinatie met andere kwetsbaarheden zou dit mogelijk te misbruiken kunnen zijn door een ongeauthenticeerde kwaadwillende.

Voor enkele kwetsbaarheden is reeds proof-of-concept code gepubliceerd.

Het NCSC verwacht binnen afzienbare tijd werkende exploitcode om deze kwetsbaarheden actief te misbruiken.

Bereik

Bereik

Platforms Producten Versies

Debian
Fedora
OpenSUSE
Ubuntu

Exim

< 4.94.2

Oplossingen

Oplossingen

Exim heeft updates uitgebracht om de kwetsbaarheden te verhelpen in 4.94.2. Voor meer informatie, zie [Link]

Debian

Debian heeft updates van exim4 beschikbaar gesteld voor Debian 10.0 (Buster) om de kwetsbaarheden te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

Fedora

Fedora heeft updates beschikbaar gesteld voor Fedora 33 en 34. U kunt deze updates installeren met behulp van het commando 'dnf' of 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:

Fedora 33 [Link]

Fedora 34 [Link]

OpenSUSE

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheden te verhelpen in OpenSUSE Leap 15.2. U kunt deze aangepaste packages installeren door gebruik te maken van 'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig downloaden van de OpenSUSE downloadserver (download.opensuse.org). Voor meer informatie, zie [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 18.04 LTS, 20.04 LTS, 20.10 en 21.04 om de kwetsbaarheid te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

CVE’s

CVE’s

CVE-2020-28007, CVE-2020-28008, CVE-2020-28009, CVE-2020-28010, CVE-2020-28011, CVE-2020-28012, CVE-2020-28013, CVE-2020-28014, CVE-2020-28015, CVE-2020-28016, CVE-2020-28017, CVE-2020-28018, CVE-2020-28019, CVE-2020-28020, CVE-2020-28021, CVE-2020-28022, CVE-2020-28023, CVE-2020-28024, CVE-2020-28025, CVE-2020-28026, CVE-2021-27216

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

high
∑ = 31
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Onduidelijk/Ja 3
Is er exploit-code beschikbaar? Proof of Concept (PoC) 4
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Ja, volledig 3
Welke toegang is er nodig? Internet 6
Vereiste credentials Geen 4
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Gemiddeld 2
Is er gebruikers interactie nodig? Eenvoudige handelingen 3
Wordt misbruik of een exploit verwacht? Ja binnenkort 3
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

high
Denial of Service Ja, Infrastructuur dienst
high
Uitvoeren van willekeurige code Ja, Root/Administrator-rechten
high
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Ja
medium
Lekken van (gevoelige) informatie Nee
low
  Versie 1.03 vandaag NCSC-2021-0391  
 
high
high
Signed-PGP →  
vandaag
high
high
NCSC-2021-0391 [1.03] Signed-PGP →
Update

Update

OpenSUSE heeft updates beschikbaar gesteld voor Exim.

  Versie 1.02 07-05-2021 NCSC-2021-0391  
 
high
high
Signed-PGP →  
07-05-2021
high
high
NCSC-2021-0391 [1.02] Signed-PGP →
Update

Update

Fedora heeft updates uitgebracht om de kwetsbaarheden te verhelpen. Verder is de tekst onder "Beschrijving" aangepast om expliciet te vermelden dat middels een combinatie van kwetsbaarheden het mogelijk zou kunnen zijn voor ongeauthenticeerde kwaadwillenden code uit te voeren met 'root' rechten.

  Versie 1.01 04-05-2021 NCSC-2021-0391  
 
high
high
Signed-PGP →  
04-05-2021
high
high
NCSC-2021-0391 [1.01] Signed-PGP →
Update

Update

Debian en Ubuntu hebben updates uitgebracht om de kwetsbaarheden te verhelpen.

  Versie 1.00 04-05-2021 NCSC-2021-0391  
 
high
high
Signed-PGP →  
04-05-2021
high
high
NCSC-2021-0391 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.