Kwetsbaarheden verholpen in Node.js

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.02 20-07-2021 NCSC-2021-0596  
 
medium
high
Signed-PGP →  
20-07-2021
medium
high
NCSC-2021-0596 [1.02] Signed-PGP →
Kenmerken

Kenmerken

  • Denial-of-Service (DoS)
  • Verhoogde gebruikersrechten
Omschrijving

Omschrijving

Er zijn kwetsbaarheden verholpen in Node.js en npm. Een kwaadwillende kan de kwetsbaarheden mogelijk misbruiken om een Denial-of-Service te veroorzaken in de npm client of binnen een service die gebruik maakt van node.js.

Tevens kan een lokale kwaadwillende zich door het misbruiken van de kwetsbaarheid met CVE-kenmerk CVE-2021-22921 SYSTEM-rechten verschaffen op het kwetsbare systeem. Deze kwetsbaarheid kan enkel misbruikt worden tijdens de installatie van node.js op Microsoft Windows systemen.

Bereik

Bereik

Platforms Producten Versies

OpenSUSE

Node.js

< 12.22.2 < 14.17.2 < 16.4.1

Oplossingen

Oplossingen

Node.js heeft updates uitgebracht om de kwetsbaarheden te verhelpen. Voor meer informatie, zie [Link]

OpenSUSE

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheden te verhelpen in OpenSUSE Leap 15.2 en 15.3. U kunt deze aangepaste packages installeren door gebruik te maken van 'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig downloaden van de OpenSUSE downloadserver (download.opensuse.org). Voor meer informatie, zie:

openSUSE 15.2 [Link] [Link] [Link]

openSUSE 15.3 [Link]

CVE’s

CVE’s

CVE-2020-7774, CVE-2021-22918, CVE-2021-23362, CVE-2021-27290, CVE-2021-3449, CVE-2021-3450

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 26
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Onduidelijk/Ja 3
Is er exploit-code beschikbaar? Nee (nog niet) 1
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Beperkt 2
Welke toegang is er nodig? Internet 6
Vereiste credentials Geen 4
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Gemiddeld 2
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Niet op korte termijn 1
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

high
Denial of Service Ja, Infrastructuur dienst
high
Uitvoeren van willekeurige code Nee
low
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Ja
medium
Lekken van (gevoelige) informatie Nee
low
  Versie 1.02 20-07-2021 NCSC-2021-0596  
 
medium
high
Signed-PGP →  
20-07-2021
medium
high
NCSC-2021-0596 [1.02] Signed-PGP →
Update

Update

OpenSUSE heeft updates uitgebracht om de kwetsbaarheden te verhelpen in OpenSUSE 15.2.

  Versie 1.01 15-07-2021 NCSC-2021-0596  
 
medium
high
Signed-PGP →  
15-07-2021
medium
high
NCSC-2021-0596 [1.01] Signed-PGP →
Update

Update

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheden met kenmerk CVE-2021-22918, CVE-2021-23362 en CVE-2021-27290 te verhelpen in OpenSUSE Leap 15.3.

  Versie 1.00 12-07-2021 NCSC-2021-0596  
 
medium
high
Signed-PGP →  
12-07-2021
medium
high
NCSC-2021-0596 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.