Kwetsbaarheid verholpen in Apache Tomcat

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.06 05-08-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
05-08-2020
medium
medium
NCSC-2020-0418 [1.06] Signed-PGP →
Kenmerken

Kenmerken

  • (Remote) code execution (Gebruikersrechten)
Omschrijving

Omschrijving

De ontwikkelaars van Apache Tomcat hebben een kwetsbaarheid verholpen die een kwaadwillende op afstand mogelijk in staat stelt willekeurige code uit te voeren onder de rechten van de applicatie. Dit is mogelijk indien:

  • de kwaadwillende de controle heeft over een bestand op de server;
  • gebruik wordt gemaakt van PersistenceManager in combinatie met een FileStore;
  • de PersistenceManager is geconfigureerd met sessionAttributeValueClassNameFilter="null", of gebruik maakt van een filter die te soepel is afgesteld;
  • de kwaadwillende de locatie op de server weet van het door hem of haar beheerde bestand.
Bereik

Bereik

Platforms Producten Versies

Debian
Fedora
OpenSUSE
Red Hat
SUSE
Ubuntu

Apache Tomcat

< 7.0.104 & >= 7.0.0 < 8.5.55 & >= 8.5.0 < 9.0.35 & >= 9.0.0.M1 < 10.0.0-M5 & > =10.0.0-M1

Oplossingen

Oplossingen

Apache heeft updates uitgebracht om de kwetsbaarheid te verhelpen in Tomcat 7.0.104, 8.5.55, 9.0.35 en 10.0.0-M5. Voor meer informatie, zie [Link]

Debian

Debian heeft updates van Tomcat beschikbaar gesteld voor Debian 9.0 (Stretch) om de kwetsbaarheid te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

Fedora

Fedora heeft een update beschikbaar gesteld voor Fedora 31 & 32. U kunt deze updates installeren met behulp van het commando 'dnf' of 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie vindt u op:

Fedora 31 [Link]

Fedora 32 [Link]

OpenSUSE

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in OpenSUSE Leap 15.0 en Leap 15.1. U kunt deze aangepaste packages installeren door gebruik te maken van 'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig downloaden van de OpenSUSE downloadserver (download.opensuse.org). Voor meer informatie, zie [Link]

Red Hat

Red Hat heeft updates beschikbaar gesteld voor Red Hat Enterprise Linux 6 en 7. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 16.04 LTS om de kwetsbaarheid te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

CVE’s

CVE’s

CVE-2020-9484

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 23
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Nee 1
Is er exploit-code beschikbaar? Proof of Concept (PoC) 4
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Ja, volledig 3
Welke toegang is er nodig? LAN/directe omgeving 4
Vereiste credentials Gewone gebruiker 2
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Complex 1
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Niet op korte termijn 1
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

medium
Denial of Service Nee
low
Uitvoeren van willekeurige code Ja, Gebruikersrechten
medium
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Nee
low
Lekken van (gevoelige) informatie Nee
low
  Versie 1.06 05-08-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
05-08-2020
medium
medium
NCSC-2020-0418 [1.06] Signed-PGP →
Update

Update

Canonical heeft updates beschikbaar gesteld voor Tomcat.

  Versie 1.05 13-07-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
13-07-2020
medium
medium
NCSC-2020-0418 [1.05] Signed-PGP →
Update

Update

Debian heeft updates beschikbaar gesteld om de kwetsbaarheid in Apache Tomcat te verhelpen voor Debian 9.0 (Strech).

  Versie 1.04 23-06-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
23-06-2020
medium
medium
NCSC-2020-0418 [1.04] Signed-PGP →
Update

Update

Fedora heeft updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in Fedora 31 & 32.

  Versie 1.03 11-06-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
11-06-2020
medium
medium
NCSC-2020-0418 [1.03] Signed-PGP →
Update

Update

Red Hat heeft updates beschikbaar gesteld voor Tomcat.

  Versie 1.02 03-06-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
03-06-2020
medium
medium
NCSC-2020-0418 [1.02] Signed-PGP →
Update

Update

Er is een Proof-of-Concept verschenen die de kwetsbaarheid uitbuit. Daarnaast is op het internet informatie beschikbaar gesteld die gedetailleerd beschrijft hoe de kwetsbaarheid door een kwaadwillende kan worden misbruikt. De oorspronkelijke inschaling van Medium/Medium blijft echter ongewijzigd.

  Versie 1.01 25-05-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
25-05-2020
medium
medium
NCSC-2020-0418 [1.01] Signed-PGP →
Update

Update

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in OpenSUSE Leap 15.0 en Leap 15.1.

  Versie 1.00 22-05-2020 NCSC-2020-0418  
 
medium
medium
Signed-PGP →  
22-05-2020
medium
medium
NCSC-2020-0418 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.