Kwetsbaarheden verholpen in BIND

Deze pagina gebruikt slimmigheden om officiële advisory platte tekst naar HTML om te zetten. Daarbij kan die informatie worden verminkt. De "Signed-PGP" versies waarnaar verwezen wordt zijn normatief (maar deze zijn minder leesbaar).
Publicatie Kans Schade    
  Versie 1.05 06-05-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
06-05-2021
medium
high
NCSC-2021-0382 [1.05] Signed-PGP →
Kenmerken

Kenmerken

  • Denial-of-Service (DoS)
  • (Remote) code execution (Gebruikersrechten)
Omschrijving

Omschrijving

ISC heeft kwetsbaarheden verholpen in BIND. De kwetsbaarheden kunnen door een kwaadwillende op afstand worden misbruikt voor het veroorzaken van een Denial-of-Service of, in beperkte omstandigheden, het uitvoeren van willekeurige code onder de rechten van named.

Uitvoeren van willekeurige code is met de standaard configuratie van BIND niet mogelijk. Hiervoor dient de DNS server geconfigureerd te zijn om gebruik te maken van GSS-TSIG. Deze configuratie is gebruikelijk wanneer BIND in samenwerking met Samba en Active Directory wordt ingezet. GSS-TSIG maakt gebruik van een eigen SPNEGO key-uitwisseling welke onder 32-bits architectuur misbruikt kan worden voor uitvoeren van willekeurige code. Code gecompileerd voor 64-bits architecturen zal bij misbruik crashen en geen code-executie tot gevolg hebben.

Bereik

Bereik

Platforms Producten Versies

Debian
Fedora
OpenSUSE
Oracle Enterprise Linux
Red Hat Enterprise Linux
SUSE Linux Enterprise
Ubuntu

ISC BIND

< 9.11.31 < 9.16.15 < 9.17.12

Oplossingen

Oplossingen

ISC heeft updates uitgebracht om de kwetsbaarheden te verhelpen in BIND 9.11.31, 9.16.15 en 9.17.12. Om de kwetsbaarheid met kenmerk CVE-2021-25216 te verhelpen verwijdert ISC de code voor SPNEGO uit de broncode. Omdat andere implementaties van key-uitwisselingssystemen als MIT en Heimdal Kerberos breed beschikbaar en toepasbaar zijn, is de SPNEGO implementatie van ISC BIND overbodig geworden. Inzet van deze update vereist mogelijk controle op aanwezigheid en inzetbaarheid van dergelijke onderliggende programmatuur.

Voor meer informatie, zie [Link] [Link] [Link]

Debian

Debian heeft updates van bind9 beschikbaar gesteld voor Debian 10.0 (Buster) om de kwetsbaarheden te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

Fedora

Fedora heeft updates beschikbaar gesteld voor Fedora 34. U kunt deze updates installeren met behulp van het commando 'dnf' of 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

OpenSUSE

De ontwikkelaars van OpenSUSE hebben updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in OpenSUSE Leap 15.2. U kunt deze aangepaste packages installeren door gebruik te maken van 'zypper'. U kunt ook gebruik maken van YAST of de updates handmatig downloaden van de OpenSUSE downloadserver (download.opensuse.org). Voor meer informatie, zie:

OpenSUSE 15.2 [Link]

Oracle

Oracle heeft updates beschikbaar gesteld voor Oracle Linux 7. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

Red Hat

Red Hat heeft updates beschikbaar gesteld voor Red Hat Enterprise Linux 7. U kunt deze updates installeren met behulp van het commando 'yum'. Meer informatie over deze updates en over een eventueel handmatige installatie [Link]

SUSE

SUSE heeft updates beschikbaar gesteld om de kwetsbaarheid te verhelpen in SUSE 12 en 15. U kunt deze aangepaste packages installeren door gebruik te maken van 'YaST'. U kunt de packages ook handmatig downloaden van de SUSE FTP-server (ftp.suse.com). Voor meer informatie, zie:

SUSE 12 [Link]

SUSE 15 [Link]

Ubuntu

Canonical heeft updates beschikbaar gesteld voor Ubuntu 18.04 LTS, 20.04 LTS, 20.10 en 21.04 om de kwetsbaarheid te verhelpen. U kunt de aangepaste packages installeren door gebruik te maken van 'apt-get update' en 'apt-get upgrade'. Meer informatie kunt u vinden op [Link]

CVE’s

CVE’s

CVE-2021-25214, CVE-2021-25215, CVE-2021-25216

Kans

Kans

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen hoe groot de kans is dat deze kwetsbaarheid in het doorsnee praktijkgeval kan worden misbruikt. De punten worden bij elkaar geteld.

medium
∑ = 26
Is de kwetsbaarheid aanwezig in de standaard configuratie/ installatie? Nee 1
Is er exploit-code beschikbaar? Nee (nog niet) 1
Wordt de kwetsbaarheid in de praktijk gebruikt? Nee (nog niet) 1
Zijn er technische details beschikbaar? Beperkt 2
Welke toegang is er nodig? Internet 6
Vereiste credentials Geen 4
Hoe moeilijk is het om de kwetsbaarheid uit te buiten? Gemiddeld 2
Is er gebruikers interactie nodig? Geen handelingen 4
Wordt misbruik of een exploit verwacht? Ja binnenkort 3
Is er een oplossing beschikbaar? Korter dan twee maanden 2
Schade

Schade

Onderstaande tabel geeft in detail aan hoe wij tot de inschatting zijn gekomen voor de schade die bij een succesvolle aanval kan ontstaan. De hoogste inschaling bepaalt de totale kans op schade.

high
Denial of Service Ja, Infrastructuur dienst
high
Uitvoeren van willekeurige code Ja, Gebruikersrechten
medium
Rechten op afstand (remote [root-] shell) Nee
low
Verwerven lokale admin/root-rechten (privilege escalation) Nee
low
Lekken van (gevoelige) informatie Nee
low
  Versie 1.05 06-05-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
06-05-2021
medium
high
NCSC-2021-0382 [1.05] Signed-PGP →
Update

Update

Fedora heeft updates uitgebracht om de kwetsbaarheden te verhelpen in Fedora 34.

  Versie 1.04 06-05-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
06-05-2021
medium
high
NCSC-2021-0382 [1.04] Signed-PGP →
Update

Update

OpenSUSE heeft updates uitgebracht om de kwetsbaarheden te verhelpen.

  Versie 1.03 04-05-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
04-05-2021
medium
high
NCSC-2021-0382 [1.03] Signed-PGP →
Update

Update

SUSE heeft updates uitgebracht om de kwetsbaarheden te verhelpen.

  Versie 1.02 03-05-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
03-05-2021
medium
high
NCSC-2021-0382 [1.02] Signed-PGP →
Update

Update

Debian heeft updates uitgebracht om de kwetsbaarheden te verhelpen.

  Versie 1.01 30-04-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
30-04-2021
medium
high
NCSC-2021-0382 [1.01] Signed-PGP →
Update

Update

Ubuntu heeft updates uitgebracht om de kwetsbaarheden te verhelpen.

Oracle en Red Hat hebben updates uitgebracht om de kwetsbaarheid met kenmerk CVE-2021-25215 te verhelpen in respectievelijk Oracle Linux 7 en RHEL 7.

  Versie 1.00 29-04-2021 NCSC-2021-0382  
 
medium
high
Signed-PGP →  
29-04-2021
medium
high
NCSC-2021-0382 [1.00] Signed-PGP →

Vrijwaringsverklaring

Door gebruik van deze security advisory gaat u akkoord met de navolgende voorwaarden. Ondanks dat het NCSC de grootst mogelijke zorg heeft betracht bij de samenstelling van dit beveiligingsadvies, kan het NCSC niet instaan voor de volledigheid, juistheid of (voortdurende) actualiteit van dit beveiligingsadvies. De informatie in dit beveiligingsadvies is uitsluitend bedoeld als algemene informatie voor professionele partijen. Aan de informatie in dit beveiligingsadvies kunnen geen rechten worden ontleend.
Het NCSC en de Staat zijn niet aansprakelijk voor enige schade ten gevolge van het gebruik of de onmogelijkheid van het gebruik van dit beveiligingsadvies, waaronder begrepen schade ten gevolge van de onjuistheid of onvolledigheid van de informatie in dit beveiligingsadvies.
Op dit beveiligingsadvies is Nederlands recht van toepassing. Alle geschillen in verband met en/of voortvloeiend uit dit beveiligingsadvies zullen worden voorgelegd aan de exclusief bevoegde rechter te Den Haag. Deze rechtskeuze geldt tevens voor de voorzieningenrechter in kort geding.